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Top  Windows 7 Tips
General tips
We'll start with a few nifty tips that can make your desktop more interesting, make it easier to get around and increase your computer's power efficiency.
Use Hidden International Wallpapers and Themes
When you first install Windows 7, it asks for your language, time and currency. Based on your responses, it installs a set of wallpapers and themes. If you choose English (United States) for your time and currency format, for example, the available desktop backgrounds and themes will include a United States section with scenery from locations such as Maine, the Southwest and so on.
Hidden, though, are background scenery and themes from other English-speaking countries -- Australia, Canada, Great Britain and South Africa. Normally, you can't access those backgrounds or themes, but there is a simple way you can install and use them:
1. In the search box in the Start menu, type C:\Windows\Globalization\MCT and press Enter. (Note: If Windows 7 is installed in a drive other than C:, use that letter instead.)
2. Windows Explorer will launch and show you a list of subfolders under C:\Windows\Globalization\MCT: MCT-AU, MCT-CA, MCT-GB, MCT-US, and MCT-ZA. Each subfolder has wallpapers for a specific country: AU for Australia, CA for Canada, GB for Great Britain, US for the United States, and ZA for South Africa.
For any of the countries whose wallpaper and themes you want to use, go into its Theme folder, for example, C:\Windows\Globalization\MCT\MCT-ZA\Theme. Double-click the theme you see there (for example ZA).

3. That will install a shortcut to the theme and wallpapers in the Personalization section of Control Panel.
You can now use them as you would any other theme or background, by right-clicking the desktop, choosing Personalize, and choosing a background or theme. They will be listed in their own section.
Shake Your Desktop Free of Clutter
If you frequently run multiple programs simultaneously, your desktop can get extremely cluttered. This can get annoying if you're working on one program and want to minimize all the other windows -- in previous versions of Windows you had to minimize them individually.
With Windows 7's "shake" feature, though, you can minimize every window except the one in which you're currently working -- in a single step. Click and hold the title bar of the window you want to keep on the desktop; while still holding the title bar, shake it quickly back and forth until all of the other windows minimize to the taskbar. Then let go. To make them return, shake the title bar again.
You can accomplish the same thing by pressing the Window key-Home key combination -- although doing that is not nearly as much fun.
Get a Power Efficiency Report
Have a laptop and want to get more battery life out of it? Windows 7 includes a hidden built-in tool that will examine your laptop's energy use and make recommendations on how to improve it. To use it:
1. Run a command prompt as an administrator. To do this, type cmd in the search box, and when the cmd icon appears, right-click it and choose "Run as administrator."
2. At the command line, type in the following:
powercfg -energy -output \Folder\Energy_Report.html
where \Folder represents the folder where you want the report to be placed.
3. For about a minute, Windows 7 will examine the behavior of your laptop. It will then analyze it and create a report in HTML format in the folder you specified. Double-click the file, and you'll get a report -- follow its recommendations for ways to improve power performance.

Modify UAC
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A laptop's power efficiency report.
The User Account Control security feature was one of the most reviled additions to Windows Vista, with good reason -- its constant warning messages asking for permission to continue many operations drove users around the bend. UAC has been significantly improved in Windows 7 so that it's not as intrusive as in Vista, but you can still tweak it if you like.
Here's how to turn UAC on or off, and make it less or more intrusive than the default:
1. Go to the Control Panel --> User Accounts and Family Safety.
2. Click User Accounts, then click Change User Account Control settings.
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Modifying UAC.
3. From the screen that appears, use the slider to select the level of protection you want. Here are the four levels and what they mean:
Always notify me. Think of this as UAC Classic. It works like Vista's UAC: When you make changes to your system, when software is installed or when a program tries to make a change to your system, an annoying prompt appears.
Default -- Notify me only when programs try to make changes to my computer. This is, obviously, the default; make a change yourself and UAC leaves you alone. When a program makes a change, a prompt appears and your desktop goes dark, just like it does in Vista. Otherwise, UAC sits there silently.
Notify me only when programs try to make changes to my computer (do not dim my desktop). This setting is identical to the default setting, with one difference: It won't dim your desktop so that you only see the UAC prompt asking you to take action. This presents a slightly elevated security risk over the default setting, because theoretically a program could allow a malicious program to interfere with the UAC prompt.
Never notify me when: In this one, UAC is completely turned off. This is, of course, an insecure option and not recommended for most users.
After you make the selection, click OK. Depending on the selection you made, you may need to restart your system for it to take effect.
Start Menu tips
Many people overlook the Start Menu, rarely using it except as a jumping off point to run an application or get to the Control Panel. But there's actually plenty you can do with it.
Search the Internet from the Start Menu
The Start Menu's search box is a convenient way to search through your PC -- but you can also have it do double-duty and perform Internet searches as well. To enable this feature:
1. In the Start Menu search box, type GPEDIT.MSC and press Enter to run the Group Policy Editor.
2. Go to User Configuration --> Administrative Templates --> Start Menu and Taskbar.
3. Double-click "Add Search Internet link to Start Menu," and from the screen that appears, select Enabled. Then click OK and close the Group Policy Editor.
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4. From now on, when you type a search term in the Search box on the Start Menu, a "Search the Internet" link will appear. Click the link to launch the search in your default browser with your default search engine.
Customize the Shut Down Button
The default action of the Start Menu's Shut down button is to turn off your PC. If you want to use the button for another action, such as restarting your PC, you click the arrow to the right of the Shut down button and select an action from the drop-down menu.
What if you rarely shut your PC down completely but frequently restart it? You can change the Shut down button's default action to be Restart -- or Switch user, Log off, Lock, Sleep or Hibernate.
To change your default, right-click the Start button and select Properties. On the Start Menu tab, click the "Power button action" drop-down menu and select which action you want to be the default. Then click OK, and OK again.
Add a Videos Link to the Start Menu
The Windows 7 Start Menu includes links to your Pictures and Music folders, but not to your Videos folder. If you watch a lot of videos and want a link to them on your Start Menu, here's what you can do:
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Displaying the Videos folder on the Start Menu.

1. Right-click the Start button and select Properties.
2. On the screen that appears, go to the Start Menu tab and click Customize.
3. In the dialog box that appears, scroll to the bottom, look for the Videos section, select "Display as a link," and click OK and then OK again.
If you'd prefer that Videos display as a menu, with links to files and submenus, instead select "Display as a menu."
Windows Explorer tips
Windows Explorer is the heart and soul of the Windows interface, and overall it works quite well. But you can make it better.
Use check boxes to select multiple files
In order to select multiple files for an operation such as copying, moving or deleting in Windows Explorer, you generally use the keyboard and the mouse, Ctrl-clicking every file you want to select. But if you're mouse-centric, there's a way to select multiple files in Windows 7 using only your mouse, via check boxes. To do it:
1. In Windows Explorer, click Organize, and then select "Folder and search options."
2. Click the View tab.
3. In Advanced Settings, scroll down and check the box next to "Use check boxes to select items." Click OK.
4. From now on, when you hover your mouse over a file in Windows Explorer, a check box will appear next to it; click it to select the file. Once a file is selected, the checked box remains next to it; if you uncheck it, the box will disappear when you move your mouse away.
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Selecting multiple files using your mouse and check boxes.
Open a command prompt at any folder
Command prompt fans will welcome this tip. With it, when you're in Windows Explorer, you can open a command prompt to any folder. This tip does exactly what the Windows XP PowerToy "Open Command Window Here" does.
To use it, hold down the Shift key and right-click a folder, then choose "Open command window here" from the context menu that appears. (Note that this tip doesn't work in the Documents folder.)
Protect the privacy of your Explorer searches
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Select "Enabled" to protect search privacy.
When you search through your PC from Windows Explorer, you can see the most recent searches that have been performed. If you share a PC and don't want others to see what you've searched for, you can turn off the recent searches feature:
1. In the Start menu's Search box, type GPEDIT.MSC and press Enter to launch the Group Policy Editor.
2. Go to User Configuration --> Administrative Templates --> Windows Components --> Windows Explorer.
3. Double-click "Turn off display of recent search entries in the Windows Explorer search box" and select Enabled from the screen that appears. Then click OK. The recent searches feature will now be turned off.

Set a New Windows Explorer Launch Folder
When you run Windows Explorer, it always opens to the Libraries folder. That's fine if you use Microsoft's default file organization, which designates Libraries as the overall container for your folders. But what if you don't? You might prefer to have Windows Explorer open to Computer or any other folder you choose. Here's how to do it:
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Changing the default Explorer location.
1. Right-click the Windows Explorer icon on the taskbar (it's the one that looks like a folder), and then right-click the Windows Explorer icon from the context menu that appears and select Properties. The Windows Explorer Properties dialog box appears.
2. You'll have to edit the Target field on the Shortcut tab of this dialog box in order to change the default location at which Explorer opens.
If you want Explorer to open to a specific folder, simply enter the name of the folder, substituting your folder name for Folder, below, like this:
%windir%\explorer.exe c:\Folder 
So to open Explorer to the folder named Budget, you would type this in the Target field:
%windir%\explorer.exe c:\Budget
If you want Explorer to open to special, pre-set locations, such as Computer, you'll need to enter special syntax in the Target field. Following is a list of three common locations and the syntax to use, followed by the syntax for the Libraries folder in case you ever want to revert to the default.
· Computer: %windir%\explorer.exe ::{20D04FE0-3AEA-1069-A2D8-08002B30309D} 
· My Documents: %windir%\explorer.exe ::{450D8FBA-AD25-11D0-98A8-0800361B1103} 
· Network: %windir%\explorer.exe ::{208D2C60-3AEA-1069-A2D7-08002B30309D} 
· Libraries: %SystemRoot%\explorer.exe 
3. After you've changed the Target field, click OK. Next time you launch Windows Explorer, it will open to the new location you've designated.
Show all Your Drives in Windows Explorer
Depending on your system settings, when you go to Computer in Windows Explorer, you may be in for a shock -- you may not see all your drives such as memory card readers if those drives are empty. If this disconcerts you, there's a simple way for you to see them even if there's nothing there:
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Having Explorer show empty drives.
1. Launch Windows Explorer and press the Alt button to reveal the top menu.
2. Select Tools --> Folder Options and click the View tab.
3. Under "Advanced settings," uncheck the box next to "Hide empty drives in the Computer folder." Click OK. The drives will now always be visible.
Build Your Own Internet Search Connector
Windows 7 has a very useful new feature called a Search Connector that lets you search through a Web site from right inside Windows Explorer. With it, you type in a search term and select the Search Connector for the site you want to search; Explorer searches the Web site without having to open Internet Explorer, and the results appear inside Windows Explorer. Click any of the results to head there using your default Web browser.
Normally, you'll need to get each Search Connector from the Web site through which you want to search, and very few Connectors are available. Sites normally need to adhere to OpenSearch standards in order for their Connectors to work.
However, there's a work-around that will let you easily build your own Search Connector for any site, using Windows Live Search as a kind of go-between. Don't worry, you don't need to know any code to write a Connector. Just follow these steps:
1. Copy the following text and paste it into Notepad. The text you'll need to change is in bold, all-caps text:
<?xml version="1.0" encoding="UTF-8"?>
<OpenSearchDescription xmlns="http://a9.com/-/spec/opensearch/1.1/" xmlns:ms-ose="http://schemas.microsoft.com/opensearchext/2009/">
<ShortName>NAME YOUR SEARCH</ShortName>
<Description>DESCRIPTION OF SEARCH</Description>
<Url type="application/rss+xml" template="http://api.bing.com/rss.aspx?source=web&query={searchTerms} site:SITENAME.COM&web.count=50"/>
<Url type="text/html" template="http://www.bing.com/search?q={searchTerms}+site:SITENAME.COM"/>
</OpenSearchDescription>
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Adding a new Search Connector.
2. In place of NAME YOUR SEARCH, type in the name of the search as you want it to appear. In our case, we're going to build a Search Connector for Computerworld, so we'll just type in Computerworld.
3. In place of DESCRIPTION OF SEARCH, type in a longer description of the search. In our instance, it will be Search through Computerworld.
4. In the two SITENAME.COM entries, enter the Web site's domain. Don't use the http:// or www -- just the domain name. In our instance it will be computerworld.com.
5. To the right of "count=", type in the number or results you want to appear. In our instance, we'll keep it at 50.
6. In our example, here's what the code should look like (no bold necessary):
<?xml version="1.0" encoding="UTF-8"?>
<OpenSearchDescription xmlns="http://a9.com/-/spec/opensearch/1.1/" xmlns:ms-ose="http://schemas.microsoft.com/opensearchext/2009/">
<ShortName>Computerworld</ShortName>
<Description>Search through Computerworld</Description>
<Url type="application/rss+xml" template="http://api.bing.com/rss.aspx?source=web&query={searchTerms} site:computerworld.com&web.count=50"/>
<Url type="text/html" template="http://www.bing.com/search?q={searchTerms}+site:computerworld.com"/>
</OpenSearchDescription>
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Results from a custom Search Connector.
7. Save the file in Notepad, choose UTF-8 from the Encoding drop-down box near the bottom of the Save As screen, and give it an .osdx extension. In our instance, we'll call the file Computerworld.osdx.
8. In Windows Explorer, right-click the .osdx file and select Create Search Connector. The Search Connector will be created.
9. You can now use the Search Connector. To get to it, in Windows Explorer go to YourName --> Searches --> Connector, where YourName is your account name, and Connector is the name of the Connector.
Taskbar Tips
One of the most significant changes to the Windows 7 interface is its new taskbar, which acts more like the Mac OS X dock than the Windows taskbar of old. Here are a few quick tips for using the new taskbar and tweaks for taking charge of it.
Speed Up the Display of Thumbnails on the Taskbar
One of the nicest things about the taskbar is that when you hover your mouse over the icons in it, you can see thumbnail previews of all open windows for each of those applications. When you do so, there is a slight delay before the thumbnail appears. But you can make the thumbnails display more quickly by using a Registry hack.
Important: Always create a Restore Point before editing the Windows Registry. If you don't know how to create a Restore Point or find your way around the Windows Registry, see "The tweaker's guide to the Windows Registry." 
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1. Launch the Registry Editor by typing regedit in the Search box and pressing Enter.
2. Go to HKEY_CURRENT_USER\Control Panel\Mouse.
3. Double-click MouseHoverTime. The default value you'll see is 400 -- which means 400 milliseconds. Type in a new, smaller value -- 150 is a good bet. Then click OK and exit the Registry Editor. You'll have to log off or restart your computer for the change to take effect.
Rearrange Taskbar Icons
It's easy to rearrange the icons across the bottom of the screen -- simply drag an icon to where you want it to live. You can also add icons to the taskbar by dragging them from an application, and delete the icons by highlighting them and pressing the Delete key.
Take Control of the Taskbar Notification Area
The notification area, at the far right of the taskbar, shows system messages and alerts, and displays the icons of programs and services that typically run in the background, such as Windows 7's wireless service. But what determines when, how and which icons show up there seems one of Windows' great mysteries.
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Customizing the taskbar notification area.
There's a simple way to find out, and better yet, to customize it.
1. Right-click the taskbar, select Properties, and from the dialog box in the notification area section, click Customize.
2. For each application, select from the drop-down box whether you want the icon and notifications to always be displayed, to never be displayed or to have an icon appear only when there's a notification of some kind. Click OK when you're done.
You can also customize the system icons and services that appear there, including the clock, volume, network, power and Action Center icons. At the bottom of the same screen, click "Turn system icons on or off," and from the screen that appears, choose whether to turn on or off the icon and notifications. Click OK twice when you're done.
See Taskbar Thumbnails Without a Mouse
If you're a fan of using the keyboard rather than your mouse whenever possible, you can move your cursor from icon to icon in the taskbar without a mouse -- and still see thumbnail previews. Press Windows key-T, and you'll move the focus to the leftmost icon on the taskbar. Then, while still pressing the Windows key, press T again to change the focus to the next icon to the right. You can keep doing this as long as you like.
Launch Taskbar Apps Without a Mouse
Likewise, you can launch any program on the taskbar without the mouse. Press the Windows key and the number that corresponds to the position of the application on the taskbar -- for example, Windows key-1 to launch the left-most application on the taskbar, Windows key-2 to launch the second left-most application and so on.
Run Multiple Copies of Applications from the Taskbar
The Windows 7 taskbar serves a dual purpose, which can get confusing at times. It's used to launch programs, and also to switch between programs that are running. So you launch a program by clicking its icon, and also switch to that program after it's running by clicking its icon.
But what if you want to launch a second instance of the program? Once the program is running, it seems there's no way to launch a second instance, because when you click its icon, you only switch to the running instance.
There's a simple fix: If a program is already running and you want to launch a second instance from the taskbar, hold down the Shift key and click the icon. A second instance will launch. You can keep launching new instances this way.
Get back the Quick Launch bar
Windows 7's new taskbar functions as a program launcher as well as task switcher. As a result, the old Quick Launch bar, the area on the left side of the taskbar that contained shortcuts for frequently used programs, has been banished. However, if you really miss the little applet, you can add it back. Here's how to do it:
1. Right-click the taskbar and choose Toolbars --> New Toolbar.
2 . You'll be asked to select a folder for where the new toolbar should live. In the Folder text box at the bottom of the dialog box, enter this text:
%userprofile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch
After you do that, click Select Folder. A link for the Quick Launch bar will be added to the taskbar. It will be on the right of the taskbar, just to the left of the Notification area.
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The Quick Launch bar docked on the right. 
It's not particularly useful docked all the way to the right with no application icons showing, so we're going to have to do a bit of work on it to make it useful. Right-click the taskbar and, in the pop-up menu, remove the check next to "Lock the taskbar." Now right-click Quick Launch and remove the checks next to Show Text and Show Title.
Once you've done that, drag the vertical triple dotted line next to the Quick Launch bar to the left until you expose its icons. To prevent further changes, right-click the taskbar and check Lock the taskbar. You can now use the Quick Launch bar as you could in Windows XP and Vista, including adding icons to it and deleting them.
67 WINDOWS 7 HIDDEN TIPS & TRICKS 

1. Problem Steps Recorder
As the local PC guru you're probably very used to friends and family asking for help with their computer problems, yet having no idea how to clearly describe what's going on. It's frustrating, but Microsoft feels your pain, and Windows 7 will include an excellent new solution in the Problem Steps Recorder.
When any app starts misbehaving under Windows 7 then all your friends need do is click Start, type PSR and press Enter, then click Start Record. If they then work through whatever they're doing then the Problem Steps Recorder will record every click and keypress, take screen grabs, and package everything up into a single zipped MHTML file when they're finished, ready for emailing to you. It's quick, easy and effective, and will save you hours of troubleshooting time.
2. Burn images
Windows 7 finally introduces a feature that other operating systems have had for years - the ability to burn ISO images to CDs or DVDs. And it couldn't be much easier to use. Just double-click the ISO image, choose the drive with the blank disc, click Burn and watch as your disc is created.
3. Create and mount VHD files
Microsoft's Virtual PC creates its virtual machine hard drives in VHD files, and Windows 7 can now mount these directly so you can access them in the host system. Click Start, type diskmgmt.msc and press Enter, then click Action > Attach VHD and choose the file you'd like to mount. It will then appear as a virtual drive in Explorer and can be accessed, copied or written just like any other drive.
Click Action > Create VHD and you can now create a new virtual drive of your own (right-click it, select Initialise Disk, and after it's set up right-click the unallocated space and select New Simple Volume to set this up). Again, you'll be left with a virtual drive that behaves just like any other, where you can drag and drop files, install programs, test partitioning software or do whatever you like. But it's actually just this VHD file on your real hard drive which you can easily back up or share with others. Right-click the disk (that's the left-hand label that says "Disk 2" or whatever) and select Detach VHD to remove it.
The command line DISKPART utility has also been upgraded with tools to detach a VHD file, and an EXPAND command to increase a virtual disk's maximum size. Don't play around with this unless you know what you're doing, though - it's all too easy to trash your system.
4. Troubleshoot problems
If some part of Windows 7 is behaving strangely, and you don't know why, then click Control Panel > Find and fix problems (or 'Troubleshooting') to access the new troubleshooting packs. These are simple wizards that will resolve common problems, check your settings, clean up your system and more.
5. Startup repair
If you've downloaded Windows 7 (and even if you haven't) it's a good idea to create a system repair disc straight away in case you run into problems booting the OS later on. Click Start > Maintenance > Create a System Repair Disc, and let Windows 7 build a bootable emergency disc. If the worst does happen then it could be the only way to get your PC running again.
6. Take control
Tired of the kids installing dubious software or running applications you'd rather they left alone? AppLocker is a new Windows 7 feature that ensures users can only run the programs you specify. Don't worry, that's easier to set up than it sounds: you can create a rule to allow everything signed by a particular publisher, so choose Microsoft, say, and that one rule will let you run all signed Microsoft applications. Launch GPEDIT.MSC and go to Computer Configuration > Windows Settings > Security Settings > Application Control Policies > AppLocker to get a feel for how this works.
7. Calculate more
At first glance the Windows 7 calculator looks just like Vista's version, but explore the Mode menu and you'll see powerful new Statistics and Programmer views. And if you're clueless about bitwise manipulation, then try the Options menu instead. This offers many different unit conversions (length, weight, volume and more), date calculations (how many days between two dates?), and spreadsheet-type templates to help you calculate vehicle mileage, mortgage rates and more.
Don't take any Windows 7 applet at face value, then - there are some very powerful new features hidden in the background. Be sure to explore every option in all Windows applets to ensure you don't miss anything important.
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CALCULATE MORE: The new Calculator is packed with useful features and functionality
8. Switch to a projector
Windows 7 now provides a standard way to switch your display from one monitor to another, or a projector - just press Win+P or run DisplaySwitch.exe and choose your preferred display. (This will have no effect if you've only one display connected.)
9. Get a power efficiency report
If you have a laptop, you can use the efficiency calculator to get Windows 7 to generate loads of useful information about its power consumption. Used in the right way, this can help you make huge gains in terms of battery life and performance. To do this you must open a command prompt as an administrator by typing 'cmd' in Start Search, and when the cmd icon appears, right-click it and choose Run as administrator.
Then at the command line, just type in 'powercfg -energy' (without quotes) and hit Return, and Windows 7 will scan your system looking for ways to improve power efficiency. It will then publish the results in an HTML file, usually in the System32 folder. Just follow the path it gives you to find your report.
10. Understanding System Restore
Using System Restore in previous versions of Windows has been something of a gamble. There's no way of telling which applications or drivers it might affect - you just have to try it and see.
Windows 7 is different. Right-click Computer, select Properties > System Protection > System Restore > Next, and choose the restore point you'd like to use. Click the new button to 'Scan for affected programs' and Windows will tell you which (if any) programs and drivers will be deleted or recovered by selecting this restore point.
11. Set the time zone
System administrators will appreciate the new command line tzutil.exe utility, which lets you set a PC's time zone from scripts. If you wanted to set a PC to Greenwich Mean Time, for instance, you'd use the command
tzutil /s "gmt standard time"
The command "tzutil /g" displays the current time zone, "tzutil /l" lists all possible time zones, and "tzutil /?" displays details on how the command works.
12. Calibrate your screen
The colours you see on your screen will vary depending on your monitor, graphics cards settings, lighting and more, yet most people use the same default Windows colour profile. And that means a digital photo you think looks perfect might appear very poor to everybody else. Fortunately Windows 7 now provides a Display Colour Calibration Wizard that helps you properly set up your brightness, contrast and colour settings, and a ClearType tuner to ensure text is crisp and sharp. Click Start, type DCCW and press Enter to give it a try.
13. Clean up Live Essentials
Installing Windows Live Essentials will get you the new versions of Mail, Movie Maker, Photo Gallery and others - great. Unfortunately it also includes other components that may be unnecessary, but if you like to keep a clean system then these can be quickly removed.
If you left the default "Set your search provider" option selected during installation, for instance, Windows Live will install Choice Guard, a tool to set your browser home page and search engine, and prevent other programs from changing them. If this causes problems later, or you just decide you don't need it, then Choice Guard may be removed by clicking Start, typing msiexec /x and pressing [Enter].
Windows Live Essentials also adds an ActiveX Control to help upload your files to Windows Live SkyDrive, as well as the Windows Live Sign-in Assistant, which makes it easier to manage and switch between multiple Windows Live accounts. If you're sure you'll never need either then remove them with the Control Panel "Uninstall a Program" applet.
14. Add network support
By default Windows Live MovieMaker won't let you import files over a network, but a quick Registry tweak will change this. Run REGEDIT, browse to HKEY_CURRENT_USER\Software\Microsoft\Windows Live\Movie Maker, add a DWORD value called AllowNetworkFiles and set it to 1 to add network support.
15. Activate XP mode
If you've old but important software that no longer runs under Windows 7, then you could try using XP Mode, a virtual copy of XP that runs in a window on your Windows 7 desktop. But there's a big potential problem, as XP Mode only works with systems that have hardware virtualisation (AMD-V or Intel VT) built-in and turned on. If you've a compatible CPU then this may just be a matter of enabling the option in your BIOS set-up program, however some high profile brands, including Sony Vaio, disable the setting for "security reasons". And that blocks XP Mode from working, too.
One solution has emerged, but it's a little risky, as essentially you'll have to alter a byte in your laptop firmware and hope this doesn't have any unexpected side-effects. Gulp.
A safer approach might be to use VirtualBox, a virtualisation tool that doesn't insist on hardware support, but then you will need to find a licensed copy of XP (or whatever other Windows version your software requires) for its virtual machine.
16. Enable virtual Wi-Fi
Windows 7 includes a little-known new feature called Virtual Wi-Fi, which effectively turns your PC or laptop into a software-based router. Any other Wi-Fi-enabled devices within range - a desktop, laptop, an iPod perhaps - will "see" you as a new network and, once logged on, immediately be able to share your internet connection.
This will only work if your wireless adapter driver supports it, though, and not all do. Check with your adapter manufacturer and make sure you've installed the very latest drivers to give you the best chance.
Once you have driver support then the easiest approach is to get a network tool that can set up virtual Wi-Fi for you. Virtual Router (below) is free, easy to use and should have you sharing your internet connection very quickly.
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If you don't mind working with the command line, though, maybe setting up some batch files or scripts, then it's not that difficult to set this up manually. 
17. Explore God Mode
Windows 7 has changed Control Panel a little, but it's still too difficult to locate all the applets and options that you might need. God Mode, however, while not being particularly godlike, does offer an easier way to access everything you could want from a single folder.
To try this out, create a new folder and rename it to:
[image: Windows 7 god mode]
The first part, "Everything" will be the folder name, and can be whatever you want: "Super Control Panel", "Advanced", "God Mode" if you prefer.
The extension, ED7BA470-8E54-465E-825C-99712043E01C, must be entered exactly as it is here, though, including the curly brackets. When you press [Enter] this part of the name will disappear, and double-clicking the new folder will display shortcuts to functions in the Action Centre, the Network and Sharing Centre, Power options, troubleshooting tools, user accounts and others - more than 260 options in total.
[image: Windows 7 god mode]
18. Right-click everything
At first glance Windows 7 bears a striking resemblance to Vista, but there's an easy way to begin spotting the differences - just right-click things.
Right-click an empty part of the desktop, for instance, and you'll find a menu entry to set your screen resolution. No need to go browsing through the display settings any more.
Right-click the Explorer icon on the taskbar for speedy access to common system folders: Documents, Pictures, the Windows folder, and more.
And if you don't plan on using Internet Explorer then you probably won't want its icon permanently displayed on the taskbar. Right-click the icon, select 'Unpin this program from the taskbar', then go install Firefox, instead.
19. Display the old taskbar button context menu
Right-click a taskbar button, though, and you'll now see its jumplist menu. That's a useful new feature, but not much help if you want to access the minimize, maximize, or move options that used to be available. Fortunately there's an easy way to get the old context menu back - just hold down Ctrl and Shift as you right-click the taskbar button.
20. Desktop slideshow
Windows 7 comes with some very attractive new wallpapers, and it's not always easy to decide which one you like the best. So why not let choose a few, and let Windows display them all in a desktop slideshow? Right-click an empty part of the desktop, select Personalise > Desktop Background, then hold down Ctrl as you click on the images you like. Choose how often you'd like the images to be changed (anything from daily to once every 10 seconds), select Shuffle if you'd like the backgrounds to appear in a random order, then click Save Changes and enjoy the show.
[image: Windows 7 desktop slideshow]
DESKTOP SLIDESHOW: Select multiple background images and Windows will cycle through them
21. RSS-powered wallpaper
And if a slideshow based on your standard wallpaper isn't enough, then you can always create a theme that extracts images from an RSS feed. For example, Long Zheng has created a few sample themes to illustrate how it works. Jamie Thompson takes this even further, with a theme that always displays the latest BBC news and weather on your desktop. And MakeUseOfhave a quick and easy tutorial showing how RSS can get you those gorgeous Bing photographs as your wallpaper. 
22. Customise the log-on screen
Changing the Windows log-on screen used to involve some complicated and potentially dangerous hacks, but not any more - Windows 7 makes it easy. 

First, browse to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\Background in REGEDIT, double-click the DWORD key called OEMBackground (not there? Create it) and set its value to 1.

Now find a background image you'd like to use. Make sure it's less than 256KB in size, and matches the aspect ratio of your screen as it'll be stretched to fit.

Next, copy that image into the %windir%\system32\oobe\info\backgrounds folder (create the info\backgrounds folders if they don't exist). Rename the image to backgroundDefault.jpg, reboot, and you should now have a custom log-on image.

Alternatively, use a free tweaking tool to handle everything for you. Logon Changer displays a preview so you can see how the log-on screen will look without rebooting, while the Logon Screen Rotator accepts multiple images and will display a different one every time you log on.
23. Recover screen space
The new Windows 7 taskbar acts as one big quick launch toolbar that can hold whatever program shortcuts you like (just right-click one and select Pin To Taskbar). And that's fine, except it does consume a little more screen real estate than we'd like. Shrink it to a more manageable size by right-clicking the Start orb, then Properties > Taskbar > Use small icons > OK.
24. Enjoy a retro taskbar
Windows 7 now combines taskbar buttons in a way that saves space, but also makes it more difficult to tell at a glance whether an icon represents a running application or a shortcut. If you prefer a more traditional approach, then right-click the taskbar, select Properties, and set Taskbar Buttons to "Combine when taskbar is full". You'll now get a clear and separate button for each running application, making them much easier to identify.
25. Remove taskbar buttons
One problem with the previous tip is the buttons will gobble up valuable taskbar real estate, but you can reduce the impact of this by removing their text captions. Launch REGEDIT, browse to HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics, add a string called MinWidth, set it to 54, and reboot to see the results.
26. Restore the Quick Launch Toolbar
If you're unhappy with the new taskbar, even after shrinking it, then it only takes a moment to restore the old Quick Launch Toolbar.
Right-click the taskbar, choose Toolbars > New Toolbar, type "%UserProfile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch" (less the quotes) into the Folder box and click Select Folder.
Now right-click the taskbar, clear 'Lock the taskbar', and you should see the Quick Launch toolbar, probably to the right. Right-click its divider, clear Show Text and Show Title to minimise the space it takes up. Complete the job by right-clicking the bar and selecting View > Small Icons for the true retro look.
27. Custom power switch
By default, Windows 7 displays a plain text 'Shut down' button on the Start menu, but it only takes a moment to change this action to something else. If you reboot your PC a few times every day then that might make more sense as a default action: right-click the Start orb, select Properties and set the 'Power boot action' to 'Restart' to make it happen.
28. Auto arrange your desktop
If your Windows 7 desktop has icons scattered everywhere then you could right-click it and select View > Auto arrange, just as in Vista. But a simpler solution is just to press and hold down F5, and Windows will automatically arrange its icons for you.
29. Disable smart window arrangement
Windows 7 features interesting new ways to intelligently arrange your windows, so that (for example) if you drag a window to the top of the screen then it will maximise. We like the new system, but if you find it distracting then it's easily disabled. Run REGEDIT, go to HKEY_CURRENT_USER\Control Panel\Desktop, set WindowArrangementActive to 0, reboot, and your windows will behave just as they always did.
30. Browse your tasks
If you prefer the keyboard over the mouse, you will love browsing the taskbar using this nifty shortcut. Press Windows and T, and you move the focus to the left-most icon on the taskbar. Then use your arrow keys to change the focus to other icons, and you get a live preview of every window.
31. Display your drives
Click Computer in Windows 7 and you might see a strange lack of drives, but don't panic, it's just Microsoft trying to be helpful: drives like memory card readers are no longer displayed if they're empty. We think it's an improvement, but if you disagree then it's easy to get your empty drives back. Launch Explorer, click Tools > Folder Options > View and clear 'Hide empty drives in the computer folder'.
32. See more detail
The new and improved Windows 7 magnifier offers a much easier way to zoom in on any area of the screen. Launch it and you can now define a scale factor and docking position, and once activated it can track your keyboard focus around the screen. Press Tab as you move around a dialog box, say, and it'll automatically zoom in on the currently active control.
33. Hiding the Windows Live Messenger iconIf you use Windows Live Messenger a lot, you'll have noticed that the icon now resides on the taskbar, where you can easily change status and quickly send an IM to someone. If you prefer to keep Windows Live Messenger in the system tray, where it's been for previous releases, just close Windows Live Messenger, edit the shortcut properties and set the application to run in Windows Vista compatibility mode.
34. Customise UAC
Windows Vista's User Account Control was a good idea in practice, but poor implementation put many people off - it raised far too many alerts. Fortunately Windows 7 displays less warnings by default, and lets you further fine-tune UAC to suit your preferred balance between security and a pop-up free life (Start > Control Panel > Change User Account Control Settings).
35. Use Sticky Notes
The Sticky Notes app is both simpler and more useful in Windows 7. Launch StikyNot.exe and you can type notes at the keyboard; right-click a note to change its colour; click the + sign on the note title bar to add another note; and click a note and press Alt + 4 to close the note windows (your notes are automatically saved).
36. Open folder in new process
By default Windows 7 opens folders in the same process. This saves system resources, but means one folder crash can bring down the entire shell. If your system seems unstable, or you're doing something in Explorer that regularly seems to causes crashes, then open Computer, hold down Shift, right-click on your drive and select Open in New Process. The folder will now be launched in a separate process, and so a crash is less likely to affect anything else.
37. Watch more videos
Windows Media Player 12 is a powerful program, but it still won't play all the audio and video files you'll find online. Fortunately the first freeware Windows 7 codecs package [shark007.net/win7codecs.html] has been released, and installing it could get your troublesome multimedia files playing again.
38. Preview fonts
Open the Fonts window in Windows XP and Vista and you'll see the font names, probably with icons to tell you whether they're TrueType or OpenType, but that's about it. Windows 7 sees some useful font-related improvements.
Open the new fonts window and you'll find a little preview for every font, giving you a quick idea of how they're going to look.
The tedium of scrolling through multiple entries for each family, like Times New Roman, Times New Roman Bold, Times New Roman Bold Italic and so on, has finally ended. There's now just a single entry for each font (though you can still see all other members of the family).
And there's a new OpenType font, Gabriola, added to the mix. It's an attractive script font, well worth a try the next time you need a stylish document that stands out from the crowd.
39. Restore your gadgets
Windows 7 has tightened up its security by refusing to run gadgets if UAC has been turned off, so limiting the damage malicious unsigned gadgets can do to your system. If you've disabled UAC, miss your gadgets and are happy to accept the security risk, though, there's an easy Registry way to get everything back to normal. Run REGEDIT, go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Sidebar\Settings, create a new DWORD value called AllowElevatedProcess and set it to 1. Your gadgets should start working again right away.
40. New WordPad formats
By default WordPad will save documents in Rich Text Format, just as before. But browse the Save As Format list and you'll see you can also save (or open, actually) files in the Office 2007 .docx or OpenDocument .odt formats.
41. Protect your data
USB flash drives are convenient, portable, and very easy to lose. Which is a problem, especially if they're carrying sensitive data. Fortunately Windows 7 has the solution: encrypt your documents with an extension of Microsoft's BitLocker technology, and only someone with the password will be able to access it. Right-click your USB flash drive, select Turn on BitLocker and follow the instructions to protect your private files.
[image: Bitlocker]
PROTECT YOUR DATA: Your USB flash drives can easily be encrypted with BitLocker
42. Minimise quickly with shakeIf you have multiple windows open on your desktop and things are getting too cluttered, it used to be a time-consuming process to close them all down. In Windows 7 you can use the Aero Shake feature to minimise everything in seconds, using a cool mouse gesture. Grab the title bar of the window you wish to keep open and give it a shake, and rejoice in a clear desktop area.
43. Configure your favourite music
The Windows 7 Media Centre now comes with an option to play your favourite music, which by default creates a changing list of songs based on your ratings, how often you play them, and when they were added (it's assumed you'll prefer songs you've added in the last 30 days). If this doesn't work then you can tweak how Media Centre decides what a "favourite" tune is- click Tasks > Settings > Music > Favourite Music and configure the program to suit your needs.
44. Customise System Restore
There was very little you could do to configure System Restore in Vista, but Windows 7 improves the situation with a couple of useful setup options.
Click the Start orb, right-click Computer and select Properties > System Protection > Configure, and set the Max Usage value to a size that suits your needs (larger to hold more restore points, smaller to save disk space).
And if you don't need System Restore to save Windows settings then choose the "Only restore previous versions of files" option. Windows 7 won't back up your Registry, which means you'll squeeze more restore points and file backups into the available disk space. System Restore is much less likely to get an unbootable PC working again, though, so use this trick at your own risk.
45. Run As
Hold down Shift, right-click any program shortcut, and you'll see an option to run the program as a different user, handy if you're logged in to the kids' limited account and need to run something with higher privileges. This isn't really a new feature - Windows XP had a Run As option that did the same thing - but Microsoft stripped it out of Vista, so it's good to see it's had a change of heart.
46. Search privacy
By default Windows 7 will remember your PC search queries, and display the most recent examples when searching in Windows Explorer. If you're sharing a PC and don't want everyone to see your searches, then launch GPEDIT.MSC, go to User Configuration > Administrative Templates > Windows Components > Windows Explorer, double-click "Turn off display of recent search entries..." and click Enabled > OK.
47. Tweak PC volume
By default Windows 7 will now automatically reduce the volume of your PC's sounds whenever it detects you're making or receiving PC-based phone calls. If this proves annoying (or maybe you'd like it to turn off other sounds altogether) then you can easily change the settings accordingly. Just right-click the speaker icon in your taskbar, select Sounds > Communications, and tell Windows what you'd like it to do.
48. Rearrange the system tray
With Windows 7 we finally see system tray icons behave in a similar way to everything else on the taskbar. So if you want to rearrange them, then go right ahead, just drag and drop them into the order you like. You can even move important icons outside of the tray, drop them onto the desktop, then put them back when you no longer need to keep an eye on them.
49. Extend your battery life
Windows 7 includes new power options that will help to improve your notebook's battery life. To see them, click Start, type Power Options and click the Power Options link, then click Change Plan Settings for your current plan and select Change Advanced Settings. Expand Multimedia Settings, for instance, and you'll see a new "playing video" setting that can be set to optimise power savings rather than performance. Browse through the other settings and ensure they're set up to suit your needs.
50. Write crash dump files
Windows 7 won't create memory.dmp crash files if you've less than 25GB of free hard drive space, annoying if you've installed the Windows debugging tools and want to diagnose your crashes. You can turn this feature off, though: browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl, create a new DWORD value called AlwaysKeepMemoryDump, set it to 1, and the crash dump file will now always be saved.
51. Find bottlenecks
From what we've seen so far Windows 7 is already performing better than Vista, but if your PC seems sluggish then it's now much easier to uncover the bottleneck. Click Start, type RESMON and press Enter to launch the Resource Monitor, then click the CPU, Memory, Disk or Network tabs. Windows 7 will immediately show which processes are hogging the most system resources.
The CPU view is particularly useful, and provides something like a more powerful version of Task Manager. If a program has locked up, for example, then right-click its name in the list and select Analyze Process. Windows will then try to tell you why it's hanging - the program might be waiting for another process, perhaps - which could give you the information you need to fix the problem.
[image: Resource monitor]
FIND BOTTLENECKS: Resource monitor keeps a careful eye on exactly how your PC is being used
52. Keyboard shortcuts
Windows 7 supports several useful new keyboard shortcuts.
Alt+P
Display/ hide the Explorer preview pane
Windows Logo+G
Display gadgets in front of other windows
Windows Logo++ (plus key)
Zoom in, where appropriate
Windows Logo+- (minus key)
Zoom out, where appropriate
Windows Logo+Up 
Maximise the current window
Windows Logo+Down
Minimise the current window
Windows Logo+Left
Snap to the left hand side of the screen
Windows Logo+Right
Snap to the right hand side of the screen
Windows Logo+Home
Minimise/ restore everything except the current window
53. Drag and drop to the command line
When working at the command line you'll often need to access files, which usually means typing lengthy paths and hoping you've got them right. But Windows 7 offers an easier way. Simply drag and drop the file onto your command window and the full path will appear, complete with quotes and ready to be used.
This feature isn't entirely new: you could do this in Windows XP, too, but drag and drop support disappeared in Vista. There does seem to be a new Windows 7 complication, though, in that it only seems to work when you open the command prompt as a regular user. Run cmd.exe as an administrator and, while it accepts dropped files, the path doesn't appear.
54. Customise your jumplists
Right-click an icon on your taskbar, perhaps Notepad, and you'll see a jumplist menu that provides easy access to the documents you've been working on recently. But maybe there's another document that you'd like to be always available? Then drag and drop it onto the taskbar icon, and it'll be pinned to the top of the jumplist for easier access. Click the pin to the right of the file name, or right-click it and select "Unpin from this list" when you need to remove it.
55. Faster program launches
If you've launched one instance of a program but want to start another, then don't work your way back through the Start menu. It's much quicker to just hold down Shift and click on the program's icon (or middle-click it), and Windows 7 will start a new instance for you.
56. Speedy video access
Want faster access to your Videos folder? Windows 7 now lets you add it to the Start menu. Just right-click the Start orb, click Properties > Start Menu > Customize, and set the Videos option to "Display as a link". If you've a TV tuner that works with Windows 7 then you'll appreciate the new option to display the Recorded TV folder on the Start menu, too.
57. Run web searches
The Windows 7 search tool can now be easily extended to search online resources, just as long as someone creates an appropriate search connector. To add Flickr support, say, visit I Started Something, click Download the Connector, choose the Open option and watch as it's downloaded (the file is tiny, it'll only take a moment). A "Flickr Search" option will be added to your Searches folder, and you'll be able to search images from your desktop.
58. Schedule Media Centre downloads
You can now tell Windows Media Centre to download data at a specific time, perhaps overnight, a useful way to prevent it sapping your bandwidth for the rest of the day. Launch Media Centre, go to Tasks > Settings > General > Automatic Download Options, and set the download start and stop times that you'd like it to use.
59. Multi-threaded Robocopies
Anyone who's ever used the excellent command-line robocopy tool will appreciate the new switches introduced with Windows 7. Our favourite, /MT, can improve speed by carrying out multi-threaded copies with the number of threads you specify (you can have up to 128, though that might be going a little too far). Enter robocopy /? at a command line for the full details.
60. Load IE faster
Some Internet Explorer add-ons can take a while to start, dragging down the browser's performance, but at least IE8 can now point a finger at the worst resource hogs. Click Tools > Manage Add-ons, check the Load Time in the right-hand column, and you'll immediately see which browser extensions are slowing you down.
61. An Alt+Tab alternative
You want to access one of the five Explorer windows you have open, but there are so many other programs running that Alt+Tab makes it hard to pick out what you need. The solution? Hold down the Ctrl key while you click on the Explorer icon. Windows 7 will then cycle through the Explorer windows only, a much quicker way to locate the right one. And of course this works with any application that has multiple windows open.
62. Block annoying alerts
Just like Vista, Windows 7 will display a suitably stern warning if it thinks your antivirus, firewall or other security settings are incorrect.
But unlike Vista, if you disagree then you can now turn off alerts on individual topics. If you no longer want to see warnings just because you've dared to turn off the Windows firewall, say, then click Control Panel > System and Security > Action Centre > Change Action Centre settings, clear the Network Firewall box and click OK.
63. Parallel defrags
The standard Windows 7 defragger offers a little more control than we saw in Vista, and the command line version also has some interesting new features. The /r switch will defrag multiple drives in parallel, for instance (they'll obviously need to be physically separate drives for this to be useful). The /h switch runs the defrag at a higher than normal priority, and the /u switch provides regular progress reports so you can see exactly what's going on. Enter the command
defrag /c /h /u /r
in a command window to speedily defrag a system with multiple drives, or enter defrag /? to view the new options for yourself.
64. Fix Explorer
The Windows 7 Explorer has a couple of potential annoyances. Launching Computer will no longer display system folders like Control Panel or Recycle Bin, for instance. And if you're drilling down through a complicated folder structure in the right-hand pane of Explorer, the left-hand tree won't always expand to follow what you're doing, which can make it more difficult to see exactly where you are. Fortunately there's a quick fix: click Organize > Folder and Search Options, check "Show all folders" and "Automatically expand to current folder", and click OK.
65. Faster file handing
If you hold down Shift while right-clicking a file in Explorer, then you'll find the Send To file now includes all your main user folders: Contacts, Documents, Downloads, Music and more. Choose any of these and your file will be moved there immediately.
66. Create folder favourites
If you're regularly working on the same folder in Explorer then select it in the right-hand page, right-click Favourites on the left-hand menu, and select Add to Favourites. It'll then appear at the bottom of the favourites list for easy one-click access later.
67. Disable hibernation
By default Windows 7 will permanently consume a chunk of your hard drive with its hibernation file, but if you never use sleep, and always turn your PC off, then this will never actually be used. To disable hibernation and recover a little hard drive space, launch REGEDIT, browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power, then set both HibernateEnabled and HiberFileSizePerfect to zero.
68. Create a new folder shortcut
When you need to create a new folder in Windows 7 Explorer, don't reach for the mouse. Just press Ctrl+Shift+N to create the folder in the active Explorer window, then type its name as usual.
69 81. Open a jumplist
Most people right-click a Windows taskbar icon to view its jumplist. You can also hold the left mouse button over the icon, though, then drag upwards to reveal the jumplist and choose the option you need, a more natural action that should be just a little faster.

The Bumper List of Windows 7 Secrets

1. Windows Management. By now, you’ve probably seen that Windows 7 does a lot to make window management easier: you can “dock” a window to the left or right half of the screen by simply dragging it to the edge; similarly, you can drag the window to the top of the screen to maximize it, and double-click the window top / bottom border to maximize it vertically with the same horizontal width. What you might not know is that all these actions are also available with keyboard shortcuts: 

· Win+Left Arrow and Win+Right Arrow dock; 
· Win+Up Arrow and Win+Down Arrow maximizes and restores / minimizes; 
· Win+Shift+Up Arrow and Win+Shift+Down Arrow maximizes and restores the vertical size. 
This side-by-side docking feature is particularly invaluable on widescreen monitors – it makes the old Windows way of shift-clicking on two items in the taskbar and then using the context menu to arrange them feel really painful.
2. Display Projection. Had enough of messing around with weird and wonderful OEM display driver utilities to get your notebook display onto an external projector? In that case, you’ll be pleased to know that projection is really quick and simple with Windows 7. Just hit Win+P, and you’ll be rewarded by the following pop-up window: 
[image: The Win+P Projector Settings window allows you to quickly switch display settings.]  
Use the arrow keys (or keep hitting Win+P) to switch to “clone”, “extend” or “external only” display settings. You can also access the application as displayswitch.exe. 

If you want broader control over presentation settings, you can also press Win+X to open the Windows Mobility Center, which allows you to turn on a presentation “mode” that switches IM clients to do not disturb, disables screensavers, sets a neutral wallpaper etc. (Note that this feature is also available in Windows Vista.) 
3. Cut Out The Clutter. Working on a document in a window and want to get rid of all the extraneous background noise? Simply hit Win+Home to minimize all the non-active background windows, keeping the window you’re using in its current position. When you’re ready, simply press Win+Home again to restore the background windows to their original locations. 
4. Multi-Monitor Windows Management. The earlier tip on window management showed how you can dock windows within a monitor. One refinement of those shortcuts is that you can use Win+Shift+Left Arrow and Win+Shift+Right Arrow to move windows from one monitor to another – keeping them in the same relative location to the monitor’s top-left origin. 
5. Command Junkies Only. One of the most popular power toys in Windows XP was “Open Command Prompt Here”, which enabled you to use the graphical shell to browse around the file system and then use the context menu to open a command prompt at the current working directory. In Windows 7 (and in Windows Vista, incidentally – although not many folk knew about it), you can simply hold the Shift key down while selecting the context menu to get exactly the same effect. If the current working directory is a network location, it will automatically map a drive letter for you. 
6. It’s a Global Village. If you’ve tried to change your desktop wallpaper, you’ve probably noticed that there’s a set of wallpapers there that match the locale you selected when you installed Windows. (If you picked US, you’ll see beautiful views of Crater Lake in Oregon, the Arches National Park, a beach in Hawai’i, etc.) In fact, there are several sets of themed wallpapers installed based on the language you choose, but the others are in a hidden directory. If you’re feeling in an international mood, simply browse to C:\Windows\Globalization\MCT and you’ll see a series of pictures under the Wallpaper directory for each country. Just double-click on the theme file in the Theme directory to display a rotation through all the pictures for that country. (Note that some countries contain a generic set of placeholder art for now.) 
7. The Black Box Recorder. Every developer wishes there was a way that an end-users could quickly and simply record a repro for the problem that they’re running into that is unique to their machine. Windows 7 comes to the rescue! Part of the in-built diagnostic tools that we use internally to send feedback on the product, the Problem Steps Recorder provides a simple screen capture tool that enables you to record a series of actions. Once you hit “record”, it tracks your mouse and keyboard and captures screenshots with any comments you choose to associate alongside them. Once you stop recording, it saves the whole thing to a ZIP file, containing an HTML-based “slide show” of the steps. It’s a really neat little tool and I can’t wait for it to become ubiquitous on every desktop! The program is called psr.exe; you can also search for it from Control Panel under “Record steps to reproduce a problem”. 
[image: The Problem Steps Recorder provides an easy way for users to record a problem repro for later diagnosis.]
8. The Font of All Knowledge. Long Zheng will be happy: we’ve got rid of the Add Fonts dialog that has served Windows faithfully for the last twenty years. (Of course, for most of that time, it’s been deprecated – the easy way to install a set of fonts has simply been to drag them into the Fonts folder via Control Panel.) But now font installation is really easy – we’ve added an “Install” button to the font viewer applet that takes care of the installation process: 
[image: You can install a font in Windows 7 from the standard font viewer dialog.]
There are lots of other new features built into Windows 7 that will satisfy those of a typographic bent, incidentally – grouping multiple weights together, the ability to hide fonts based on regional settings, a new text rendering engine built into the DirectWrite API, and support in the Font common file dialog for more than the four “standard” weights. For example: 
[image: The new common font dialog in Windows 7 supports more than four weights for a font.]  
9. Gabriola. As well as the other typographic features mentioned above, Windows 7 includes Gabriola, an elaborate display type from the Tiro Typeworks foundry that takes advantage of OpenType Layout to provide a variety of stylistic sets, flourishes and ornamentation ligatures: 
[image: Some sample variants of the Gabriola display font.]
10. Who Stole My Browser? If you feel like Internet Explorer is taking a long time to load your page, it’s worth taking a look at the add-ons you have installed. One of the more helpful little additions in Internet Explorer 8 is instrumentation for add-on initialization, allowing you to quickly see whether you’re sitting around waiting for plug-ins to load. Just click Tools / Manage Add-ons, and then scroll right in the list view to see the load time. On my machine, I noticed that the Research add-on that Office 2007 installs was a particular culprit, and since I never use it, it was simple to disable it from the same dialog box. 
11. Rearranging the Furniture. Unless you’ve seen it demonstrated, you may not know that the icons in the new taskbar aren’t fixed in-place. You can reorder them to suit your needs, whether they’re pinned shortcuts or running applications. What’s particularly nice is that once they’re reordered, you can start a new instance of any of the first five icons by pressing Win+1, Win+2, Win+3 etc. I love that I can quickly fire up a Notepad2 instance on my machine with a simple Win+5 keystroke, for instance. 

What’s less well-known is that you can similarly drag the system tray icons around to rearrange their order, or move them in and out of the hidden icon list. It’s an easy way to customize your system to show the things you want, where you want them. 
12. Installing from a USB Memory Stick. My wife has a Samsung NC10 netbook (very nice machine, by the way), and we wanted to install Windows 7 Beta on this machine to replace the pre-installed Windows XP environment. Like most netbook-class devices, this machine has no built-in media drive, and nor did I have an external USB DVD drive available to boot off. The solution: I took a spare 4GB USB 2.0 thumbdrive, reformatted it as FAT32, and simply copied the contents of the Windows 7 Beta ISO image to the memory stick using xcopy e:\ f:\ /e /f (where e: was the DVD drive and f: was the removable drive location). Not only was it easy to boot and install from the thumbdrive, it was also blindingly fast: quicker than the corresponding DVD install on my desktop machine. 

It’s also worth noting in passing that Windows 7 is far better suited to a netbook than any previous operating system: it has a much lighter hard drive and memory footprint than Windows Vista, while also being able to optimize for solid state drives (for example, it switches off disk defragmentation since random read access is as fast as sequential read access, and it handles file deletions differently to minimize wear on the solid state drive). 
13. I Want My Quick Launch Toolbar Back! You might have noticed that the old faithful Quick Launch toolbar is not only disabled by default in Windows 7, it’s actually missing from the list of toolbars. As is probably obvious, the concept of having a set of pinned shortcut icons is now integrated directly into the new taskbar. Based on early user interface testing, we think that the vast majority of users out there (i.e. not the kind of folk who read this blog, with the exception of my mother) will be quite happy with the new model, but if you’re after the retro behavior, you’ll be pleased to know that the old shortcuts are all still there. To re-enable it, do the following: 
· Right-click the taskbar, choose Toolbars / New Toolbar 
· In the folder selection dialog, enter the following string and hit OK: 
%userprofile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch 
· Turn off the “lock the taskbar” setting, and right-click on the divider. Make sure that “Show text” and “Show title” are disabled and the view is set to “small icons”. 
· Use the dividers to rearrange the toolbar ordering to choice, and then lock the taskbar again. 
If it’s not obvious by the semi-tortuous steps above, it’s worth noting that this isn’t something we’re exactly desperate for folks to re-enable, but it’s there if you really need it for some reason. Incidentally, we’d love you to really try the new model first and give us feedback on why you felt the new taskbar didn’t suit your needs.
14. It’s a Drag. Much play has been made of the Jump Lists feature in Windows 7, allowing applications like Windows Live Messenger to offer an easy task-based entry point. Jump lists replace the default right-click context menu in the new taskbar; another way to access them (particularly useful if you’re running Windows 7 on a one-button MacBook) is by left-clicking and dragging up in a kind of “swooshing” motion. This was designed for touch-enabled devices like the beautiful HP TouchSmart all-in-one PC, where the same gesture applies. 

Another place where you can “swoosh” (not an official Microsoft term) is the IE 8 address bar, where the downward drag gesture brings up an expanded list containing the browser history, favorites and similar entries. The slower you drag, the cooler the animation! 
15. Standards Support. Every review of Windows 7 that I’ve seen has noted the revamped WordPad and Paint applets that add an Office-like ribbon to expose their functionality. Few, however, have noticed one small but hopefully appreciated feature: WordPad can now read and write both the Word 2007-compatible Office Open XML file format but also the OpenDocument specification that IBM and Sun have been advocating: 
[image: WordPad in Windows 7 allows you to save in ODF or OOXML formats.]  
16. Windows Vista-Style Taskbar. I wasn’t initially a fan of the Windows 7 taskbar when it was first introduced in early Windows 7 builds, but as the design was refined in the run up to the beta, I was converted and now actively prefer the new look, particularly when I’ve got lots of windows open simultaneously. For those who really would prefer a look more reminiscent of Windows Vista, the good news is that it’s easy to customize the look of the taskbar to more closely mirror the old version: 
17. 
[image: The Windows 7 Taskbar can be configured for a Windows Vista compatibility view.]  
To achieve this look, right-click on the taskbar and choose the properties dialog. Select the “small icons” checkbox and under the “taskbar buttons” setting, choose “combine when taskbar is full”. It’s not pixel-perfect in accuracy, but it’s close from a functionality point of view. 
18. Peeking at the Desktop. While we’re on the taskbar, it’s worth noting a few subtleties. You’ve probably seen the small rectangle in the bottom right hand corner: this is the feature we call “Aero Peek”, which enables you to see any gadgets or icons you’ve got on your desktop. I wanted to note that there’s a keyboard shortcut that does the same thing – just press Win+Space. 
19. Running with Elevated Rights. Want to quickly launch a taskbar-docked application as an administrator? It’s easy – hold down Ctrl+Shift while you click on the icon, and you’ll immediately launch it with full administrative rights (assuming your account has the necessary permissions, of course!) 
20. One More of the Same, Please. I’ve seen a few folk caught out by this one. If you’ve already got an application open on your desktop (for example, a command prompt window), and you want to open a second instance of the same application, you don’t have to go back to the start menu. You can simply hold down the Shift key while clicking on the taskbar icon, and it will open a new instance of the application rather than switching to the existing application. For a keyboard-free shortcut, you can middle-click with the third mouse button to do the same thing. (This trick assumes that your application supports multiple running instances, naturally.) 
21. Specialized Windows Switching. Another feature that power users will love is the ability to do a kind of “Alt+Tab” switching across windows that belong to just one application. For example, if you’ve got five Outlook message windows open along with ten other windows, you can quickly tab through just the Outlook windows by holding down the Ctrl key while you repeatedly click on the single Outlook icon. This will toggle through each of the five Outlook windows in order, and is way faster than opening Alt+Tab and trying to figure out which of the tiny thumbnail images relates to the specific message you’re trying to find. 
22. Walking Through the Taskbar. Another “secret” Windows shortcut: press Win+T to move the focus to the taskbar. Once you’re there, you can use the arrow keys to select a particular window or group and then hit Enter to launch or activate it. As ever, you can cancel out of this mode by hitting the Esc key. I don’t know for sure, but I presume this shortcut was introduced for those with accessibility needs. However, it’s equally valuable to power users – another good reason for all developers to care about ensuring their code is accessible. 
23. [image: image]The Widescreen Tip. Almost every display sold these days is widescreen, whether you’re buying a notebook computer or a monitor. While it might be great for watching DVDs, when you’re trying to get work done it can sometimes feel like you’re a little squeezed for vertical space. 

As a result, the first thing I do when I set up any new computer is to dock the taskbar to the left hand side of the screen. I can understand why we don’t set this by default – can you imagine the complaints from enterprise IT departments who have to retrain all their staff – but there’s no reason why you as a power user should have to suffer from default settings introduced when the average screen resolution was 800x600. 

In the past, Windows did an indifferent job of supporting “side dockers” like myself. Sure, you could move the taskbar, but it felt like an afterthought – the gradients would be wrong, the Start menu had a few idiosyncrasies, and you’d feel like something of a second-class citizen. The Windows 7 taskbar feels almost as if it was designed with vertical mode as the default – the icons work well on the side of the screen, shortcuts like the Win+T trick mentioned previously automatically switch from left/right arrows to up/down arrows, and so on. The net effect is that you wind up with a much better proportioned working space. 

Try it – in particular, if you’ve got a netbook computer that has a 1024x600 display, you’ll immediately appreciate the extra space for browsing the Internet. For the first day you’ll feel a little out of sync, but then I guarantee you’ll become an enthusiastic convert! 
24. Pin Your Favorite Folders. If you’re always working in the same four or five folders, you can quickly pin them with the Explorer icon on the taskbar. Hold the right-click button down and drag the folder to the taskbar, and it will be automatically pinned in the Explorer Jump List. 
25. Starting Explorer from “My Computer”. If you spend more time manipulating files outside of the documents folders than inside, you might want to change the default starting directory for Windows Explorer so that it opens at the Computer node: 
[image: The Computer node in Windows 7.]  
To do this, navigate to Windows Explorer in the Start Menu (it’s in the Accessories folder). Then edit the properties and change the target to read: 
%SystemRoot%\explorer.exe /root,::{20D04FE0-3AEA-1069-A2D8-08002B30309D} 

If you want the change to affect the icon on the taskbar, you’ll need to unpin and repin it to the taskbar so that the new shortcut takes affect. It’s worth noting that Win+E will continue to display the documents library as the default view: I’ve not found a way to change this from the shell at this time. 
26. ClearType Text Tuning and Display Color Calibration. If you want to tune up your display for image or text display, we have the tools included out of the box. It’s amazing what a difference this makes: by slightly darkening the color of the text and adjusting the gamma back a little, my laptop display looks much crisper than it did before. You’d adjust the brightness and contrast settings on that fancy 42” HDTV you’ve just bought: why wouldn’t you do the same for the computer displays that you stare at every day?  
[image: image]

[image: image]
Check out cttune.exe and dccw.exe respectively, or run the applets from Control Panel. 
27. ISO Burning. Easy to miss if you’re not looking for it: you can double-click on any DVD or CD .ISO image and you’ll see a helpful little applet that will enable you to burn the image to a blank disc. No more grappling for shareware utilities of questionable parentage! 
[image: You can burn an ISO image to disk with this built-in utility in Windows 7.]

28. Windows Movie Maker. Windows 7 doesn’t include a movie editing tool – it’s been moved to the Windows Live Essentials package, along with Photo Gallery, Mail and Messenger. Unfortunately, Windows Live Movie Maker is currently still in an early beta that is missing most of the old feature set (we’re reworking the application), and so you might be feeling a little bereft of options. It goes without saying that we intend to have a better solution by the time we ship Windows 7, but in the meantime the best solution for us early adopters is to use Windows Movie Maker 2.6 (which is essentially the same as the most recent update to the Windows XP version). It’s missing the full set of effects and transitions from the Windows Vista version, and doesn’t support HD editing, but it’s pretty functional for the typical usage scenario of home movie editing. 
[image: Windows Movie Maker 2.6 is compatible with Windows 7.]  
Download Windows Movie Maker 2.6 from here: 
http://microsoft.com/downloads/details.aspx?FamilyID=d6ba5972-328e-4df7-8f9d-068fc0f80cfc  
29. Hiding the Windows Live Messenger Icon. Hopefully your first act after Windows 7 setup completed was to download and install the Windows Live Essentials suite of applications (if not, then you’re missing out on a significant part of the Windows experience). If you’re a heavy user of IM, you may love the way that Windows Live Messenger is front and central on the taskbar, where you can easily change status and quickly send an IM to someone: 
[image: Windows Live Messenger appears by default on the taskbar.]
On the other hand, you may prefer to keep Windows Live Messenger in the system tray where it’s been for previous releases. If so, you can fool the application into the old style of behavior. To do this, close Windows Live Messenger, edit the shortcut properties and set the application to run in Windows Vista compatibility mode. Bingo! 
30. Enjoy The Fish. I’m surprised that not many people seem to have caught the subtle joke with the Siamese fighting fish that is part of the default background, so I’ll do my part at keeping the secret hidden. Check out wikipedia for a clue. 
31. When All Else Fails… There are always those times when you’re in a really bad spot – you can’t boot up properly, and what you really want is something you can quickly use to get at a command prompt so you can properly troubleshoot. Windows 7 now includes the ability to create a system repair disc, which is essentially a CD-bootable version of Windows that just includes the command prompt and a suite of system tools. Just type “system repair disc” in the Start Menu search box, and you’ll be led to the utility.
Viewing the Secret Items
These are the default items that you should see on the Send To menu when you right-click on a file:
[image: Windows 7 Send To Menu] 
Hold down the Shift key while right-clicking on the icon, and then try the Send To menu… all sorts of extra options!
[image: http://www.howtogeek.com/wp-content/uploads/2009/01/image111.png]
If you want any of those to show up normally without holding down the Shift key, you can create shortcuts in the Send To folder. Just type the following into the location bar:
shell:sendto
And then drag shortcuts to your preferred folders into this folder.
[image: http://www.howtogeek.com/wp-content/uploads/2009/01/image112.png]
I’ve found that using custom shortcuts in the Send To menu can be very handy… I use them to upload images to the HTG web server on a daily basis.
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Takeaway: In this edition of the Windows Desktop Report, Greg Shultz explains how you can activate and use the real Administrator account in Microsoft Windows 7.
As you know, the User Account Control (UAC) system is the heart and soul of the security system in Microsoft Windows 7. It is designed to protect your system from inadvertent or malicious incidents that could compromise stability or security while you are logged on using an account with administrative privileges, where you have full access to the system. Of course, you can perform administrative operations simply by working through the UAC prompt. Or, if you totally dislike the UAC system, you can also easily disable it. For example, you can select the Never Notify setting on the User Account Control Setting window.
However, there certainly are times when it would just be nice to log on to your Windows 7 system with a good old-fashioned, full-fledged Administrator account. When you do, you’ll never encounter a UAC prompt.
In this edition of the Windows Desktop Report, I’ll explain how you can activate and use the real Administrator account in Windows 7.
Caveat
Now keep in mind that Microsoft has gone to great lengths to prevent you from using the real Administrator account and, as you can imagine, strongly discourages the technique I’m about to show you here. As such, I must emphasize that you should use the real Administrator account very sparingly — never make it your default modus operandi! With that being said, I also have to warn you that you use this technique at your own risk.
Activating the account
While you might think that since Microsoft discourages the use of Windows 7’s Administrator account, it is hidden deep within the bowels of the operating system. However, that’s not the case at all. In fact, to find the Administrator account you have to look no further than the Local Users and Groups tool.
To begin, open the Start menu, right-click the Computer icon, and select Manage from the context menu. When you see the Computer Management console, go to the navigation panel on the left and click the arrow next to Local Users and Groups to expand the branch. Then, click the Users folder. At this point you can see and select the Administrator account, as shown in Figure A.
Figure A
[image: http://i.techrepublic.com.com/gallery/500385-500-317.png]
Select the Administrator account.
With the Administrator account selected, click More Actions under Administrator in the Actions panel on the right and select Properties from the menu, as shown in Figure B.
Figure B
[image: http://i.techrepublic.com.com/gallery/500386-500-356.png]
Use the More Actions menu to access the Properties command.
When you see the Administrator Properties dialog box, just clear the Account Is Disabled check box, as shown in Figure C, and click OK.
Figure C
[image: http://i.techrepublic.com.com/gallery/500387-414-461.png]
The Administrator account is disabled by default.
Keep in mind that now that the Administrator Account is activated you can also work with the account in the User Accounts tool in the Control Panel.
Setting the password
By default, the Administrator account has a blank password, so the first order of business after activating the account is to set a password — preferably a complex password consisting of at least eight characters and using uppercase, lowercase, and numbers or special symbols.
With the Administrator account selected, click More Actions under Administrator in the Actions panel and select the Set Password command. You will be shown a warning that explains that resetting a password from outside the account itself can cause irreversible loss of information, as shown in Figure D.
Figure D
[image: http://i.techrepublic.com.com/gallery/500388-500-268.png]
When you select the Set Password command, you will see this warning.
However, since the Administrator Account has never been used, you can click Proceed with impunity. When you do, you’ll see the Set Password for Administrator dialog box, shown in Figure E, and can type the new password in both text boxes. Then, click OK.
Figure E
[image: http://i.techrepublic.com.com/gallery/500389-394-256.png]
You will be prompted to type the password for the Administrator account.
Stay on top of the latest Microsoft Windows tips and tricks with TechRepublic’s Windows Desktop newsletter, delivered every Monday and Thursday. Automatically sign up today!
Logging in as the Administrator
Now that you’ve activated the Administrator Account and set the password, using the account is as simple as logging off. When the Log Off operation completes, you’ll see the Welcome screen and a user icon for the Administrator Account, as shown in Figure F. To log on as the Administrator, just click the icon and provide the correct password.
Figure F
[image: http://i.techrepublic.com.com/gallery/500390-417-373.png]
You will now see the Administrator account on the Welcome page.
When you do, you’ll never encounter a UAC prompt. Again, I must emphasize that you should use the real Administrator account sparingly and never make it your default mode of operation!

What’s your take?
As you can see, it’s a relatively easy operation to activate the real Administrator account in Windows 7 once you know the technique. Now that you know how it’s done, are you likely to use the Administrator account? Have you disabled UAC? If so, do you think that you’ll re-enable it and use this technique instead? As always, if you have comments or information to share about this topic, please take a moment to drop by the TechRepublic Community Forums and let us hear from you.
Some Useful Tips
1. Your PC Won't Boot
If turning on your PC doesn't bring you into Windows, try booting from a Windows 7 DVD or a recovery disc.
[image: http://zapp5.staticworld.net/images/zoomIcon.png][image: Boot from a Windows 7 System Repair Disc, and you'll find tools to heal an unbootable PC.]
Boot from a Windows 7 System Repair Disc, and you'll find tools to heal an unbootable PC.You may already have the DVD. If Windows 7 didn't come with your computer but you installed it yourself, you have the disc. If you don't have it, you can borrow someone else's disc.
Alternatively you can borrow someone else's Windows 7 computer and use it to create a System Repair Disc (you can also do this on your own PC before it has a problem). To create the disc, click Start, type system repair, select Create a System Repair Disc, and follow the prompts.
If your computer won't boot from the CD, go into its setup screen and change the boot order so that the optical or CD/DVD drive comes before the hard drive. I can't tell you exactly how to do this since it differs from one PC to another. When you first turn on the computer, look for an on-screen message telling you to press a particular key 'for setup'.
If your PC fails before you can enter setup or boot from a CD, you have a hardware problem. If you're not comfortable working inside a PC, take it to a professional.
But let's assume that the CD boots. When it does, follow the prompts. Likely the utility will tell you very soon that there's a problem, and it will ask if you want to fix the problem. You do.
If it doesn't ask you, or if the disc can't fix the issue, you'll see a menu with various options. Startup Repair and System Restore are both worth trying.

2. You Can't Access the Hard Drive
If Windows can't boot because the PC can't read the hard drive, none of the solutions above will work. But that's not the worst of it: Unless you have a very up-to-date backup (and shame on you if you don't), all of your files are locked away on a possibly dead hard drive. Secondary drives you don't boot off of, both internal and external, also can die with important data locked away on them.
[image: http://zapp5.staticworld.net/images/zoomIcon.png][image: If you can't access your hard drive, Recover My Files might be able to do what its name implies.]
If you can't access your hard drive, Recover My Files might be able to do what its name implies.If the drive is making noises that you've never heard before, shut off the PC immediately. In that case you have only one possible solution, and it's expensive: Send the drive to a data-retrieval service. Drivesavers and Kroll Ontrack are the best known, although they're not necessarily better than smaller, cheaper companies. Expect to pay hundreds or even thousands of dollars. If your drive sounds okay, however, you may be able to recover the files for only $70 with GetData's Recover My Files.
If the sick drive is the one you use to boot Windows, you'll have to remove it from the PC and access it on another computer. You can do so by making it a secondary drive in a desktop PC, or by using a SATA-USB adapter such as the Bytecc USB 2.0 to IDE/SATA Adapter Kit.
The free, demo version of Recover My Files will show you which files can be recovered (almost all of them, when I tested it) and even display their contents. Once you've paid the $70 license fee, the program can copy the files to another drive. If that doesn't work, you'll need to use a retrieval service.
3. Blue Screens of Death Attack Your PC Regularly
[image: http://zapp5.staticworld.net/images/zoomIcon.png][image: BlueScreenView can show what Windows was doing before disaster struck.]
BlueScreenView can show what Windows was doing before disaster struck.One second you're working productively, the next you're staring at a blue screen filled with meaningless white text. If it happens occasionally, you curse, reboot, and get on with your work. If it happens regularly, you have a problem that needs fixing.
Windows 7 keeps logs of these "Stop Errors." (That's Microsoft's term; everyone else calls them "Blue Screens of Death," or BSoDs.) To view the logs and make sense of them, download and run BlueScreenView, a free, portable program by NirSoft (portable means you don't have to install it). The program shows you what drivers were running at the time of the crash, and highlights the likeliest suspects. If the same drivers come up from multiple crashes, you should definitely update them.
Speaking of updating drivers, you should make sure that all of them are current. SlimWare Utilities' free SlimDrivers makes this chore remarkably easy, as it scans Windows and lists which drivers need to be updated. If you register (that's free, too), it will find the drivers and run the update for you. It even offers to create a restore point before each update. Don't update all of your drivers at once, however; if you do, and one of them makes things worse, you'll have a tough time figuring out which one.
Frequent BSoDs can also be a sign of hardware problems, especially bad RAM. Although Windows 7 has its own memory-diagnostics program, I prefer the free Memtest86+, which you have to boot separately. You can download the program either as an .iso file--from which you can create a bootable CD--or as an .exe file that will install the program and its bootable operating system onto a flash drive.
4. No One Has the PC's Administrator Password
If the wrong person leaves your company in a huff, one or more PCs could be left stranded. With no one in the company knowing the password to an administrator-level account, you can't install software, change important settings, or possibly access encrypted data.
Fortunately, you can remove the password, letting you log on to that account. You do that with the Offline NT Password & Registry Editor, a bootable, text-based free program that you download as an .iso file. Double-click that file, and Windows 7 will start the process of burning it to a CD.
[image: http://zapp5.staticworld.net/images/zoomIcon.png][image: Sure your drivers are up-to-date? SlimDrivers can automate this otherwise time-consuming job.]
Sure your drivers are up-to-date? SlimDrivers can automate this otherwise time-consuming job.Boot the CD and follow these instructions. I've put the on-screen prompts in italics. After you type your answer, press Enter.
boot: Just press Enter.
Select: [1]: Above the prompt you'll see a list of hard-drive partitions. Select the right one by typing that number.
What is the path to the registry directory?...: The default is probably correct. Just press Enter.
[1]: 1
What to do? [1] ->: 1
or simply enter the username...: Type the name of the administrator account. If you're not sure what it is, all of the account names are listed above the prompt.
Select: [q] >: 1
Select: ! - quit...: !
What to do [1]: q
About to write file(s) back...: y
New run? [n]: n
# Remove the CD and reboot.
You should now be able to log on to the administrator account without a password. For security purposes, don't forget to create a new password for the account. Just be sure to remember what it is.
Next page: How do you know whether your PC is infected? What if a file disappears?
5. You Think Your PC Is Infected
[image: http://zapp5.staticworld.net/images/zoomIcon.png][image: Malwarebytes Anti-Malware might catch malicious software that your regular antivirus program missed.]
Malwarebytes Anti-Malware might catch malicious software that your regular antivirus program missed.Is your computer behaving oddly, slowing down at the wrong time, or refusing to run certain programs? It could be infected with malware. What can you do about that?
If your regular antivirus program--the one you already have up and running--hasn't stopped the questionable software, it probably can't. What you need is a second opinion--and possibly a third and a fourth.
Start with the free version of Malwarebytes Anti-Malware, a utility with an exceptional record of finding and removing malware. Download it, install it, launch it, update the database, and then perform a full scan.
Since installing and updating a cleaning utility are tasks that the infection may interfere with, it's a good idea to follow your Malwarebytes scan with other scans that don't require an installation or even an update.
On someone else's PC, download SuperAntiSpyware Portable and copy it to a flash drive. Boot the infected PC into Safe Mode, plug in the flash drive, and run the program. Since SuperAntiSpyware.com updates the portable program every day or two, you don't need to update it before the scan.
For a fourth opinion, try the F-Secure Rescue CD. This is another .iso file from which you can burn a bootable CD. Just boot from the CD and run the scan. The program will try to update its database over the Internet. If it can't, you can download an update on another PC, put it on a flash drive, and keep that plugged in while running F-Secure on the infected PC.
6. An Important File Disappears
You've been working on a report for six weeks. You have to give the speech tomorrow. The PowerPoint presentation is beautiful. It's perfect. It's...where is it?
Maybe you just moved it to another folder. Click the Start menu, type the file's name, and see what turns up.
[image: http://zapp5.staticworld.net/images/zoomIcon.png][image: Can't find a file? Make sure it didn't wind up in the Recycle Bin.]
Can't find a file? Make sure it didn't wind up in the Recycle Bin.Nothing? Maybe you've renamed it accidentally. Click Start, type a word that's in the presentation but not in many other files, and see if that gets better results. If it pulls up a lot of results, click See more results so that you can sort the found files by date.
No luck? Try the Recycle Bin. Maybe you deleted the file.
Dead end? Don't panic. You can always restore the file from the backup you made yesterday.
You don't back up? I bet you will now. As for the file you desperately need to find today, you'll have to use file-recovery software. Before I discuss specific programs, I need to lay down one absolute rule about using them: Until you've either recovered the file or given up, do not write to your hard drive. Every time you do so, you lower the odds of successfully retrieving the lost file.
Following this rule requires you to use portable file-recovery software. Download the utility on another PC and save it to a flash drive. Plug that drive into your PC, and launch the program from there.
The rule also means that you shouldn't restore your file to its original location. Save it to the flash drive, as well.
With luck, either of the following two utilities will be able to find and recover your missing file. First, try the free Recuva Portable. It's fast and simple, it can preview image formats, and it works reliably most of the time.
If that doesn't work, try Software Shelf's File-Rescue Plus. It costs $40, but you can recover up to five files with the free demo version. Strictly speaking, File-Rescue Plus isn't portable, but you have a work-around. Install it onto another computer, and then copy the program file, FileRescuePlus.exe, to your flash drive. After you pay the $40, use Notepad to create a file called key.ini containing nothing but the license key that Software Shelf sent you after you bought the program. Place key.ini on the flash drive, in the same folder as the program file.
Lost files and other disasters happen. You can take all the proper precautions, and something could still go horribly wrong, plunging you into a Windows nightmare. But follow these tips, and you should enjoy some sweet dreams.
4 Tips to Make Windows 7 Boot Faster

1. Use MSConfig
If you haven’t heard of MSConfig, get familiar with it. This tool is absolutely essential in managing many aspects of your computer’s behavior during its boot time. If you don’t know how to get to it, use the following process:
1. Press “Win + R” on your keyboard. The “Win” key is next to each “Alt” key, away from the space bar. This brings up a dialog that looks like this:
[image: boottime-run]
If you can’t find the “Win” key, or your keyboard doesn’t have one, type “run” in the search bar at the bottom of the Start menu and press “Enter”.
2: Type “msconfig” in the dialog and press “Enter” on your keyboard. This takes you to the MSConfig screen I’ve been rambling about. Once inside, click the “Startup” tab. If you recognize a program that you don’t think you need to start up when Windows boots, clear the checkbox next to it.
[image: boottime-msconfig]
Additionally, you can click the “Services” tab to disable services you know you don’t need. You must be absolutely sure that you don’t need the services and programs that you disable, or else you end up disabling something your computer needs to function properly. The consequences might make the operating system lose some functionality, but you can usually recover from this by enabling services again using the same method in this step.
3: If you use two or more operating systems on your computer and manage the boot sequence through your current Windows installation, go to the “Boot” tab and type a lower number under “Timeout.” The default timeout for Windows is 30 seconds. This makes the computer boot faster only if you plan to leave it unattended after you turn it on.
2. Device Manager
When you see the loading screen in Windows that says “Starting Windows”, the operating system loads all of your device drivers and essential services. Obviously, disabling some of the drivers that Windows loads will help speed up the loading time a bit. To do this, you must enter the device manager within Windows 7:
1: Click the Start menu and then “Control Panel”.
2: Once inside the control panel, click “Hardware and Sound.”
[image: boottime-controlpanel]
3: Under “Devices and Printers,” click “Device Manager.” This opens a window that shows you all the devices attached to your computer. Windows has to load drivers for each one of these devices.
[image: boottime-hwandsound]
4: Expand any of the device categories and explore which devices you don’t use. Right-click on any device you want and click “Disable.” This tells Windows to ignore the drivers for that device. Make sure you don’t disable any devices that your computer needs to function properly, such as the network interface or display adapter.
3. Delay Services
Let’s face it: You need the majority of the services that run on Windows’ startup. If you don’t think you can brave disabling the services, you can always delay them. When you delay a service, Windows ignores the service until enough resources are free to start the service. Once Windows finishes booting, it then loads every service you delayed. To put services on hold when Windows starts, you need to access the Services dialog in Administrative Tools:
1: Access the Control Panel using the same process mentioned in the previous tip.
2: Click “System and Security” and “Administrative Tools”.
[image: boottime-administrative]
3: In the new window that opens, double-click “Services.” Once in the “Services” dialog, right-click any service you want to delay and click “Properties,” as in the image below.
[image: boottime-services]
4: Click the drop-down menu next to “Startup Type” and click “Automatic (Delayed).” Don’t do this to services that already have the “Manual” startup type. That just swamps your computer with unnecessary services. Check the image below if you have no idea what I’m talking about.
[image: boottime-service]
5: Click “OK” and repeat this as many times as you need to. Just don’t disable a service you’re not sure of.
4. Hardware Upgrades
While you might get away with some changes in your operating system configuration, you still may need to get new hardware for your PC. Suggested upgrades include new or additional RAM (memory) and a solid state drive (SSD). Both upgrades will raise the input/output capacity of your computer per second. Getting faster or higher quantities of RAM will always speed up the boot process, since Windows uses this piece of your computer overwhelmingly when booting.
The hard drive, on the other hand, is the slowest part of any computer, particularly because its functions rely chiefly on moving electrical parts instead of transistors. If you suspect that your hard drive is dragging down the speed of your computer, your only solution could be a solid state drive, which is completely built on transistors and memory cells. These drives usually perform up to twice as fast as a regular hard drive. Be aware, however, that some solid state drives might perform more slowly with algorithmic file processing/decompression than regular hard drives. You’re guaranteed, regardless, that you’ll get a faster boot/run time than a regular hard drive.
Although the processor regularly doesn’t affect boot time, it might slow you down anyway. To check this, open your task manager (Ctrl + Shift + Esc) while Windows boots and monitor CPU usage through the entire duration. If you constantly see the CPU usage at 100%, it’s time to get a new CPU. Note, however, that CPUs need to use the same socket number as your motherboard. You might have to replace your motherboard also in order to fit a newer next-gen CPU. If you’re not comfortable making this upgrade yourself, you’ll have to pay someone to do it. Just remember that the sooner you get this over with, the better your experience with Windows will be.
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